Emergency Maintenance
Incident Report for BGHDDevelopment LLC - Status
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 19:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 22, 2021 - 18:39 UTC
Identified
We are performing emergency maintenance on some of our sites. There may be downtime.
Posted Oct 22, 2021 - 14:54 UTC
This incident affected: Websites (Website, Download Site, Depends/Addons Site).